OpenAlchemist !

You are not logged in.

Announcement

Registrations are currently closed, because of too much spam. We are looking for a solution.

#1 2010-05-31 22:46:38

schlobinux
New member
Registered: 2008-10-14
Posts: 9

Check for ClanGDI

openalchemist makes use of ClanGDI, but doesn't check for it. Following patch should fix that (hopefully the forum won't mess up the formatting)

Code:

diff -Naurp openalchemist-0.4-src.orig/configure.ac openalchemist-0.4-src/configure.ac
--- openalchemist-0.4-src.orig/configure.ac     2009-10-27 13:09:00.000000000 +0100
+++ openalchemist-0.4-src/configure.ac  2010-06-01 00:34:19.000000000 +0200
@@ -20,7 +20,8 @@ PKG_CHECK_MODULES(clanlib,
        clanGL-2.1 >= $REQUIRED_CLANLIB_VERSION
        clanSound-2.1 >= $REQUIRED_CLANLIB_VERSION
   clanVorbis-2.1 >= $REQUIRED_CLANLIB_VERSION
-], [], [echo "This program needs ClanLib >= 2.0 (clanCore, clanApp, clanDisplay, clanGL, clanSound, clanVorbis)"; exit])
+  clanGDI-2.1 >= $REQUIRED_CLANLIB_VERSION
+], [], [echo "This program needs ClanLib >= 2.0 (clanCore, clanApp, clanDisplay, clanGL, clanSound, clanVorbis, clanGDI)"; exit])
 
 % Outputfiles
 % AC_CONFIG_HEADERS([src/config.h])

As a side note, I'm trying to get openalchemist to build on ppc, but ClanLib makes heavy use of SSE2 and doesn't always have C fallback code. Especially, ClanSound, ClanVorbis and ClanMikMod was missing, but the ClanLib Fedora maintainer kindly submitted a patch for that. However, as ClanGDI was not tested for, we though this was not needed and the C fallback code for ClanGDI is yet to be written.

Offline

 

Board footer

Powered by FluxBB